Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Magnet not linking to tixati

by Guest on 2014/09/01 05:08:49 PM    
When I am using a torrent site, and I click on the magnet nothing is happening. This was working fine two days ago, it was linking just fine, but now nothing. I have not done anything or made any changes. Is there any suggestions? Please don't make answer too technical as I am just learning.
by Guest on 2014/09/01 10:47:34 PM    
What web browser are you using?  Firefox/Chrome/IE etc.

Tixati checks for the magnet/torrent association when it starts up, and should popup a warning if the operating system isn't using it as the default handler.  So it seems like this is something going on in your browser.

If you have Firefox, go to the Edit menu, then Preferences, then at the top click the Applications choice.  In the "Content-Type" column mine has "magnet" and then Action has "Use tixati" but you can change things right there if it doesn't.

I don't know how it works in the other browsers but someone else might be able to help...
by Guest on 2014/09/02 01:19:54 PM    
I am using Linux (Kubuntu 14.04) with the same result. I tried both Portable and Install versions of Tixati. File Types are set and Tixati opens if i click magnet in Chromium but the link doesn't get pasted in Tixati... even if it was already open. If i use KTorrent for example magnet links function as they should. Thank you for help.
by Guest on 2014/09/04 04:12:00 AM    
I was having this exact same problem with the most recent version of Tixati. I just re-installed version 1.97 and it's working perfectly now. I think it was a problem with 1.98, because not on 1.97 it's working perfectly
by mehdus on 2014/09/04 07:12:27 AM    
Edit the tixati.desktop file with a text editor and replace "%F" with "%U" in the line that starts with "Exec="

You can find tixati.desktop in /usr/share/applications/ or ~/.local/share/applications if you are using the portable version.

If that doesn't help, try adding association manually, in a terminal:
xdg-mime default tixati.desktop x-scheme-handler/magnet
by Guest on 2014/09/05 08:00:04 AM    
Yes, mehdus! adding "%U" at the end of "Command" line in Application Launcher does the trick (what does it do anyway instead of "%F"?). I just put Linux Portable executable into same folder as Portable Windows Tixati and added launcher manually to Application Launcher and settings stay the same for both OS's this is great!
Thanks again, mehdus.
by mehdus on 2014/09/06 09:03:38 AM    
It is explained here

If the application is able to open URLs in addition to local files then %u or %U can be used instead of %f or %F.

This should be Tixati's default.
by Guest on 2014/09/06 11:17:01 PM    
Version 1.99 fixes this permanently, makes %U the default.

BTW %U just means that the program will accept URLs in addition to files on the command line.  %F is just files.
by Krytical on 2015/04/28 10:51:04 PM    
Any idea why this isn't working for me?

Tixati 2.11
Ubuntu 15 desktop
Chrome 42.0.2311.90 (64-bit)

By default Tixati knows transmission is default, and asks to change to tixati.
I select tixati as default, and tixati believes it is default if I choose "check"  but when I select a magnet link, transmission opens.

So I uninstall transmission, and nothing happens when I select a magnet link.

So I manually run "xdg-mime default tixati.desktop application/x-bittorrent x-scheme-handler/magnet"

And now Tixati will open when I click on a magnet link, but nothing is added to queue.

So lastly I check both of my tixati.desktop files, and made sure they are the same.
here is the contents:
GenericName=BitTorrent Client
Comment=Share files over BitTorrent
Exec=tixati %U

However still, when I click on a magnet link in chrome, tixati will open, but no torrent added to queue.
by Guest on 2015/05/05 05:31:44 PM    

It works fine when loading through firefox, typing gvfs-open "magnet-link" in terminal, and with typing tixati "magnet-link" in terminal. It is just with chrome. Chrome does not work for me as well. it starts tixati but does not load the magnet-link.
by Guest on 2015/09/01 12:03:49 AM    
any luck with this?
by Guest on 2015/09/01 01:18:27 PM    
what version of tixati are you using? 2.16 should be work fine.
by ChasUGC on 2022/10/24 01:06:35 AM    
It use to work for me until I tried to install transmission because I was blocked at a certain library from using torrents. I uninstalled transmission and then I uninstalled Chrome. Then, the links in Pirate Bay did nothing. When I installed Chrome, the links opened a blank tab in Chrome. In Microsoft Edge, the link wants to open Google Chrome. The only way to get the links to work is to copy them and paste them in Tixati. I want to get to the bottom of this problem. Magnet links are associated with Tixati in my Registry and it works with other websites, just not Pirate Bay. Tixati is also my default magnet handler in that program. I believe the problem must be in the registry somewhere else, because it effects Microsoft Edge as well. But, I'm stumped.

This web site is powered by Super Simple Server