Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

I'm Using Ubuntu 23.04 and Tixati won't let me select a Download

by wolf on 2023/09/17 09:18:43 AM    
I'm relatively new to linux and up until now, I would manually mount the hard drive where my torrent files are located (this is also the location of my Tixati folder).

After following a post on about automatically mounting a hard drive at startup by editing the fstab file, my hard drive is now automatically automounted.

The problem is that even though it's the same drive and folder as before, Tixati keeps giving me the "Download Folder Not Found" error.

When I press the "Select a New Download Folder" button and navigate to my download folder on the hard drive, Tixati will not let me select it.

How do I fix this issue?

Screenshots:  (notice how the "OK" button is greyed out so I can't select the Download folder).
by Guest on 2023/09/17 03:21:04 PM    
are you sure you/tixati have permission to write to that folder?
can you select any other folder within that same folder?
by Guest on 2023/09/17 07:02:17 PM    
First of all, you can use GUI tool like GNOME Disks to set mount options. It also changes fstab records, but virtual filesystems in modern desktop environments are more complex, and may need other configuration changes in background.

Files on both Linux and Windows filesystems have access control records. If that volume was created on another system, its user ids for access control can be alien to your system. File managers can sometimes override access rules for external mounts (like USB flash drives) for convenience, but Tixati is a regular user process (unless you run it in some kind of sandbox/jail), and is subject to regular access checks, just like any other program. You need to make sure that files and folders holding them have ownership and access mask that allow read-write access for current user.

There are also mount options that allow to override access restrictions for the whole volume altogether. However, if you intend to use it with your system constantly, it's better to change ownership for all files on it properly.
by wolf on 2023/09/17 09:59:56 PM    
>are you sure you/tixati have permission to write to that folder?

The problem is that Tixati doesn't allow me to select any folder on that hard drive.

How do I give Tixati permission to read & write to the hard drive and all of its folders and files?

>can you select any other folder within that same folder?

No, I can't.
by wolf on 2023/09/18 02:35:28 AM    
I fixed the issue by unmounting my hard drive, running the following command in the Terminal, and restarting my computer:

sudo ntfsfix /dev/<your disk and partition. In my case it was sdb1>
by Guest on 2023/09/18 03:41:07 PM    
You don't grant access to Tixati specifically, you grant access to the user account that is used to run Tixati process. You can open properties in file manager, check permissions, and set them for the whole hierarchy of directories. There's plenty of explanations on the internet.

That's just the most obvious thing to check. Maybe there's other reason. How did you install Tixati?
by wolf on 2023/09/20 07:38:06 AM    
The issue was not with Tixati, it was with my hard drive. It was in read-only mode.

After running ntfsfix, the problem was resolved.

This web site is powered by Super Simple Server