Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Need to restart Tixati to get some torrents to start downloading

by RandomSonofabitch on 2023/08/14 12:20:52 AM    
Hi there
First of all, superb work from all involved in this project!

Just a heads up with 3.19 (and I think 3.18) - previously, I didn't notice this problem.

When I add some magnet links, they go into the list of DL's correctly, but sometimes the first one starts (or one of them starts) but the rest just kind of sit at 'fetching Meta info' - but never get anywhere. To fix it, I just need to restart Tixati and the meta info downloads pretty much right away - and then the actual downloads start as normal.

On Linux - Mint Mate. Latest version.

Not a big issue, but I need to keep an eye on it until all downloads start - or else it just sits there..
by Guest on 2023/08/14 05:49:26 AM    
How are you adding the magnet-links? Add button? ctrl-v?
Have you tried just stopping and starting those torrents when this happens?
How often does this happen?
Are you adding multiple magnet links at once?
by Guest on 2023/08/16 04:18:39 PM    
When this condition next happens

In the peers tab
Is the Metadata stuck ? IE: The percentage bar graph showing some infill blocks or just perimeter?

If you see this again... What are the peer Client names? (ie qBittorrent/uTorrent)

by Guest on 2023/08/17 12:13:19 PM    
Will double check, but I'm pretty sure I've tried stopping and resuming - but it didn't make a difference.
They were added by either running the file to create the new torrent in the list or opening a direct magnet link.

I'll check the other queries too, next time I see it. As mentioned, only ever experienced this in the most recent version(s).
by Guest on 2023/08/17 01:03:34 PM    
Clicked on magnet link. Torrent shows in Tixati as Hash link. "Shows downloading" 7(7).

Peers. One has "transferring metadata" all others have "waiting for metadata" progress.
Some of these (maybe 2-3 out of 30) has a full, blue, progress bar.

Showing download speed initially a few kb. Now sitting about 300bytes/s

No dialog asking where to save the file and it does not start..

I try to stop and start download. Shows a couple of kb download speed. All peers set to waiting for metadata.
A couple of peers have 'ignored (bad metadata)' and are coloured red.

Still no download - or asking for where to save the download..
Now around 33 seeders and still no download.

Stop tixati, ensure not running in task bar, start tixati..

No immediate download but i click on 'remove' on the peers that show 'ignored (bad metadata)' and immediately (though could be coincidence) the download dialog box comes up to ask me where to save it. DOwnload starts normally..

I don't normally do that, so possibly coincidence.
by Guest on 2023/08/21 02:13:05 AM    
OK first of all, if there are no seeds, or nobody has Metadata there is nothing for anybody to share...
(There will be nothing to download for you)
So assuming this download IS indeed live and seeded;
From what you've said, this does appear to be live

Peers. One has "transferring metadata" all others have "waiting for metadata" progress.
Some of these (maybe 2-3 out of 30) has a full, blue, progress bar.

OK when this happens again

Tixati - TRANSFERS window
Select the hash-link which won't get the Metadata
click on the PEERS tab

You should see IP's of your peers.
Now double click the 1st line and a popup should happen
Select EventLog in that popup (3rd tab in the popup)
Now select Detail level to 4

Wait a minute or so and see what comes up in this popup debug. It might be self explanatory it might be some error you can't decide what to think.

Repeat for a few peers or until you think something can be learned ?

Maybe post the info back here?

I had issues with this too, look at my forum post:

Maybe this issue has similarities?

NEXT, we want to find out the CLIENT name of these peers (to see if there is common theme, like "Transmission")

Layout button (top-right underneath the yellow question mark)
'Select Columns'
Peers View tab (3rd tab)
TICK the box that says 'Client'
Then click the close button.

Then revert to TRANSFERS which isn't working and see if you can share any logs or tell me if any specific clients are causing issue
(for me, it always seems to be Transmission that I get problems with Metadata.

Alternatively. Use a website that lets you download *.torrent file which bypasses the need for Metadata stage.

Hopefully something will bring us closer to resolving this for you?

This web site is powered by Super Simple Server