Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Trouble Connecting to Seeds

by Guest on 2023/07/31 12:47:32 PM    
Hi, I'm having issues with my Tixati and connecting to seeders/peers.

The tracker shows a larger number of seeds, e.g. 10 or 12, but my torrent status stays at:
Downloading 1 (1) 2 (2)

It seems fairly consistent in only connecting to 1 or 2 seeders, despite many more being available in the trackers.
The download speed is very slow as a result.

My connection settings are all default, 8 download slots etc.

I used it previously with Windows 10 and the same network, but with Windows 11 it has this issue.

by notaLamer on 2023/08/12 01:35:08 AM    
If this only started with Windows 11, its probably related to how it affects incoming connections at the firewall. For Bittorrent to function its vital to make AND receive connections. Receiving connections requires the firewall to allow them and your entire network configuration to forward unknown connections to your PC and the app (Tixati). The keyword is port-forwarding.
by Guest on 2023/08/21 05:09:17 PM    

Are you using a VPN or your normal internet connection?

It does firstly seem like a port-forwarding issue as per notaLamer's observations above.

If you are on a VPN, most companies don't offer port-forwarding so this (testing procedure) probably won't work in that specific case.
Some VPN providers do offer forwarding - but you'd need to configure it first

If you're just on non-VPN connection

In Tixati SETTINGS (GEARS Icon) >>  NETWORK >> Incoming Ports
Do you have a tick present in the UPNP box. That normally asks your router to hold open a port for this very purpose.
Maybe you can check if your router has UPNP enabled too by logging into the router user interface

Some other issues it could be;

Your ISP Internet Provider may be using Carrier-Grade-NAT ("CGNAT") Especially you're using a cellular network internet connection LTE/4G/5G?

In Tixati SETTINGS (GEARS Icon) >>  NETWORK >> Incoming Ports
Try turning off 'Random Port Interval' to NEVER
Try changing your port from a random 5-digit high number to 4 digit like '6699' or '5060' could be worth a try.
You'd also need to change the Random Port Range from '10000'-'50000' to perhaps around '2000'-'9999'

There's also a Port Forwarding website you can try to TEST if your incoming port is working.
With Tixati running, take a note of the 'TCP/UDP port for connections and messages'

Google "yougetsignal open ports" and enter the PORT number in the page and test (with Tixati running)
In Tixati a second place to get the port is HOME button and bottom right pane is the Port.

Try disabling your WIN firewalls for a matter of seconds and retrying the test again, if it works, re-enable firewalls test if it fails - could be a local firewall issue?
But remember to re-enable your firewall or take notes of what settings you change so you can revert it all back.

This web site is powered by Super Simple Server