Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

File Allocating Slow

by Guest on 2021/06/10 11:44:09 PM    
I've been using Tixati for the past few years and have had no problems with it until now.

When installing Tixati onto a new computer, it seems to start to allocate files for about thirty minutes or higher before starting a download.

Is there anyway to stop this, I've tried reinstalling Tixati and the options, as well as installing programs on different drives.

by notaLamer on 2021/06/11 03:36:43 PM    
Settings > Transfers > Files > File allocation

Sparse (default): fastest without doubt, but I do not recommend it because it will unnecessarily fragment your files. File size becomes known to system but space is not allocated until data is written.
Fast Allocate: recommended, should be instant too and makes sure all file space needed is allocated at once. If there's enough free continuous space, there will be 0 fragments! No need for defragmentation
Full Pre-Write: not recommended, if you load a 20 GB transfer, you'll need to wait to write 20 GB out before starting download.

Make sure you don't have Full Pre-Write enabled.
by tkalfaoglu on 2023/10/17 05:38:48 PM    
even with Sparse setting, creating an 8GB download takes over 10 minutes on an SSD drive! Fedora Linux and latest Tixati.
by shag00 on 2023/11/05 01:31:50 PM    
Fast allocation allocates at about 2Mb/sec which is a long way from my idea of fast. On a dedicated to torrenting disk. There  is some fundamental error with this and subsequent downloading of large files (50GB+) in the beginning my download speed can be as high as 10,000 Kb/s at some stage, normally over 50% it always slows to rate less than (roughly, 500kb/s) and then drop to 0, jump to 1,500 kb's and repeat this till 100% downloaded. The response of Tixati (say click on a peer) during this time can also be very slow. The problem appears worse on Linux but the disk format seems to make no difference, ie, NTFS is just as bad as EXT4. It seems to be in the queuing to write to the disk.
by Guest on 2023/12/27 12:00:30 AM    
On the official manual page for Settings - Transfers - Files i.e.  the screenshot clearly shows that the Sparse File Allocation method is the default, whereas in the text below option #2 i.e. Fast Allocate is mentioned as the default.

The online manual really, really needs a thorough overhaul.

This web site is powered by Super Simple Server