Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

[Bug] 2.83 The saving of throttle value (number) loads a wrong v

by notaLamer on 2021/06/10 04:04:12 PM    
For example when I enter outgoing throttle = 1000 (KB/s) in the input field, after Tixati restart it resets to 1024.
Windows 7 x64, Tixati 2.83 portable. Cannot replicate on a fresh install. Did not have this before on 2.81
by Bugmagnet on 2021/06/11 04:41:15 AM    
What units did you select in Settings > User Interface > Output Formatting > Largest Unit?

k/m/g/t or ki/mi/bi/ti
by notaLamer on 2021/06/11 03:20:33 PM    
Good catch! Yes this is it. Confirmed.

My settings
Byte Gi
Byte in Graphs Ki
Numbers 1
Numbers in Graphs 1
use "K" instead "k" [yes]
Remove 'i' from 'Ki/Mi/Gi/Ti' [yes]

yep replicatable with these settings
---
Default portable 2.83 settings
Byte T
Byte in Graphs T
Numbers T
Numbers in Graphs T
use "K" instead "k" [yes]
Remove 'i' from 'Ki/Mi/Gi/Ti' [yes]
---
"1001" Outgoing as Bytes "1"

Changing "Largest Unit old value" to "Largest Unit new value" - the actual value of the input field
I executed this in the following order:

Bytes: 1 to k = 1001
Bytes: k to M = 1001
Bytes: G to T = 1001
Bytes: T to Ki = 1001
Bytes: Ki to Mi = 977
Bytes: Mi to Ki = 977
Bytes: Ki to Gi/Ti = 977
Bytes: Ti to T = 977
Bytes: T to Ti = 1001
Bytes: Ti to T = 977
at this step, updating Bytes in Charts correctly resets to 1001 as it should, instead of 977

Basically the settings are all wrong and weird, not updating when needed (e.g. Ti to T switch) but if the update has not been executed, changing an irrelevant number (Bytes in Charts) forces an update.

This all appears to be an issue with the new loading mechanism.
Additionally, my Tixati install (channels.dat and core.dat are 600 MB combined) usually incorrectly warns me that DHT is off upon startup when it is actually enabled. DHT Startup mode: ON.




This web site is powered by Super Simple Server