Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Web interface not working anymore with Windows Defender Firewall

by Guest on 2020/07/24 11:40:48 PM    
Since the last windows update I do not get the WebUI to work anymore.
I run tixati on a small laptop but want to manage it from my Desktop so I use within my private network the WebUI.
All works fine if I turn off the firewall, but the moment I turn it on, I get no response from the Web interface any more.

Thanks for any suggestions
by Guest on 2020/07/24 11:59:57 PM    
what version of Windows and what version of tixati?

has anything else changed?

if you roll back the last windows update, does tixati WebUI work?
by Guest on 2020/07/25 12:58:00 AM    
Windows 10
Version 2004 (OSBuild 19041.188)
Tixati 2.74 (Portable, 64bit)

nothing has changed, the version of Tixati was the same, I am certain the windows update changed the Firewall behaviour.

and no, i am not rolling the windows update back for the web interface only ;)
by Guest on 2020/07/25 11:55:55 AM    
how exactly does it not work? is there an error you get?

do you use a login for the webui?

what browser do you use?
by Guest on 2020/07/25 08:53:00 PM    
The website times out.

Chrome:
"This site can't be reached" - "192.168.1.11 took too long to respond"
Firefox:
"The connection has timed out" - "The server at 192.168.1.11 is taking too long to respond."

I ran Diagnostics from my desktop:

Problems found:
resource (192.168.1.11) is online but isn't responding to connection attempts.

The results are the same with user and password or without, with https enabled or not.
by Guest on 2020/07/26 01:09:19 PM    
It should work because there's already a rule to allow anything Tixati related. Check for a rule named "Tixati". This rule is per program type and not per port type. I don't know why it's not working.  Make sure you are trying to connect to the right IP before adding this rule. Check with ipconfig. Try turning the webUI off and then on.

Try creating a per port rule.

Windows Defender Firewall with Advanced Security --> Left click on Inbound Rules --> Right click on Inbound Rules --> New Rule -> Port --> TCP + the port your using for webUI --> Allow the connection --> Next --> Name it "Tixati webUI" or whatever.

Edit: I just checked and I can't find the Tixati program rule either. I remember it being there. Can someone else check to confirm?

But when I run nmap on my computer, the port shows up as open. I have the default Windows firewall enabled and in standard configuration. No 3rd party firewall. I don't have any issues with it.
by Guest on 2020/07/26 01:27:32 PM    
Edit2: Couldn't edit my last post. I realized why. It's because on Windows Server, "Notify me when Windows Defender Firewall blocks a new app." is unchecked by default. I'm going to reset firewall to defaults and fix my rules. You shouldn't have to reset it.
by Guest on 2020/07/26 02:41:07 PM    
it sounds like this is a windows problem.

is it working now with the changes you have made?
by Guest on 2020/07/27 03:23:18 AM    
Yes. But I'm not the original poster. OP, please run "ipconfig" in cmd to double check you are connecting to the right IP locally. It's most likely dynamic unless you made it ststic through manually configuring it or with DHCP reservations.
by Guest on 2020/07/27 08:42:36 PM    
Of course it is a windows problem.

What solved it for me was:

I deleted the existing rules in the Defender Firewall, started Tixati again and let it create the rule from scratch.

It seems that the update somehow messed up the old existing rule for Tixati.




This web site is powered by Super Simple Server