Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Very slow download - capped at 250k - DHT / NAT / UPnP issue?

by Smass101 on 2020/05/23 03:19:05 PM    
Hi everyone,
Have been having major speed related problems with Tixati for an indeterminate amount of time - pretty sure it's only been over the last few weeks to a month.
I haven't changed anything with my setup and i cant remember if this started after a new version.
My D/L speed winds up to 250k when i start a single torrent, then just stops there and goes no faster or slower. If i start a second it appears to deducts the speed for that download from the 250, slowing both torrents down.

I am pretty useless on the networking side of things so have only tried modest troubleshooting of my own using Google searches. Hoping you can help / advise?

When i launch Tixati I see on the transfers page "DHT:port unconfirmed" and "0 incoming connections received"

When i click the Home page i can see the following error type messages:

[20:07:55]  NAT-PMP mapping UDP port XXXXX on gateway XXX.XXX.X.X > socket error waiting for reply: Timed out (50434)
[20:07:55]  UPNP mapping UDP port XXXXX on gateway XXX.XXX.X.X > command failed with error 402 Invalid Args
[20:07:55]  mapping UDP port XXXXX on gateway XXX.XXX.X.X will be retried every 5 minutes

I have enabled UPnP on my router as it was switched off but this hasnt made any difference.

Any thoughts on what this might be or what i can do to speed things up?
Thanks.
by Guest on 2020/05/31 05:29:05 AM    
I would suggest your router is blocking or denying the request.

Also if you cap your upload rate it will limit your download rate.
by Smass101 on 2020/06/10 07:44:33 AM    
Looks like it could be both!
There was a cap set on the downloads for no reason that i could work out, i have removed that and now "enjoying" speeds around 1.0M
I still have the "0 incoming connections" message and the same error messages. I've logged into the router and tried sniffing around some of the settings.... UPnP is enabled and nothing jumps out as being catastrophically wrong - although i'm not 100% sure what i'm looking for exactly.... Can you assist any further?




This web site is powered by Super Simple Server