Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

UPNP mapping sent to wrong gateway

by JohnDoe1982 on 2020/05/20 10:33:21 PM    
Hello there!

I found another similar topic, but no answers there. So here we go:
I'm using Tixati on Win7 with built in VPN connection to a nice VPN provider. I use Win7 because Win10 disconnected the VPN on problems (like reconnecting of the physical internet connections once per day) while Win7 just waited 30 or 60 seconds and reconnected without any user intervention. My VPN provider supports UPNP and it is activated in the web interface of the provider. The problem is that Tixati shows it sends the UPNP mapping requests to the standard gateway of the physical ethernet connection, not the VPN's gateway. What can I do to change this?
by Guest on 2020/05/21 01:50:27 PM    
Here are a few options I can think of. Some of these may not apply to you but I'm saying it anyways for whoever reads this.

1) Disable UPnP (not recommended if you use it for port forwarding on your VPN. You can disable it if your VPN doesn't support UPnP port forwarding.)

2) The way your VPN provider sets up their VPN needs to be adjusted. The reason this is happening is because of how they add the routes. The default gateway is still set as your home router(check with "ipconfig" or "route -4 print") In this case, Tixati is using home router's IP for UPnP and not the VPN network's default gateway.

3) Find a program that let's you specify UPnP settings like the port to forward and the gateway IP. (I haven't tested it so I don't know if this one works:  )

4) Run your own wireguard or openvpn VPN server. (Advanced and not recommended but you can setup port forwarding this way.)
by Guest on 2020/05/21 02:09:48 PM    
more info:   (requires Java 11. This is the only program I could find for doing this.) If you try using this, please let us know if it works.

This web site is powered by Super Simple Server