Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Tixati Error Message  "error creating directory"

by radische on 2018/05/30 08:15:48 AM    
"error creating directory. The system cannot find the file specified (2)"

And the download, of course fails. The above message occurs in the "Status" box after clicking on "Start" This happens with each file I attempt to download.

Windows 10, Tixati Version 2.57
by radische on 2018/05/31 02:10:21 AM    
Perhaps I should have mentioned above that my first (and only) attempt at fixing the problem was to uninstall Tixati and than install again. Nothing changed and the error appeared no matter what torrent I was attempting to download.
by Guest on 2018/06/02 09:28:36 AM    
are you sure you have permission to modify your download folder?

have you tried changing your download folder?

do ALL torrents you try to download fail with this error message?

in the files tab, what does the status column for the file(s) display?
by Guest on 2018/06/03 10:22:38 PM    
I get the same "error creating directory: The system cannot find the file specified. (2)"

The above error is exactly what is listed under the "Status" column under the "Files" tab.

I am using Tixati v2.57, 64-Bit Windows Build on a Microsoft Windows Version 10.0.16299.461 machine.

Here is a sample "File Operations Log":


(Log removed by Mod and sent to devs)

by Guest on 2018/06/06 12:34:45 AM    
Is there a bug ID opened somewhere for this issue, i.e., how do I track the issue?
by KH on 2018/06/29 12:11:36 AM    
As a previous reply stated, you need to change your download folder to somewhere else and see what happens, if indeed this is happening on ALL torrents you start.  Something is odd with your system, according to your own log file.  The following lines are relevant:

   31:42.712> AsyncFileSys::CreateDir C:\Users\yourusername\my_tor_dir\The_File_I_Am_Trying_To_Download.2017.S02E13.HDTV.x264-SVA 6 us = 1
   31:42.737> AsyncFileSys::CreateDir CB e=2 us = 1

This suggests that C:\Users\yourusername\my_tor_dir does not exist, according to the error code 2, which is ERROR_PATH_NOT_FOUND.

From the Windows API docs at

ERROR_PATH_NOT_FOUND - One or more intermediate directories do not exist; this function will only create the final directory in the path.

If you want to solve this, the first step is to change your download location to somewhere else, perhaps a folder on your desktop.  There is probably a permission problem or something else weird with that particular folder you are using.  Regardless, there's no Tixati bug here as far as the submitted information shows.
by Guest on 2019/02/03 05:25:06 PM    
tried to fix this for hours. so i uninstalled and reinstalled and it worked fine.
by Guest on 2020/04/03 12:43:32 AM    
Right click the folder you are downloading to and select properties at bottom.
Then security tab up top.
Then click edit to change permissions.
Then select the Allow Full Control box for everyone.
by Guest on 2020/06/06 12:53:53 AM    
by Guest on 2020/04/02 06:43:32 PM  
His/her solution was absolutely the answer.
Thanks so much.
Just allow permissions (I like another person stated it started when I bought a new PC which obviously required the change of permissions) for changing full access for anyone to download (to my Download file site)
    John V.
by Guest on 2022/05/09 05:33:58 PM    
You have to run Tixati as an admin (right click on Tixati app and choose "run as administrator").
Giving rights to everyone on a folder may be not very wise..
by carlos on 2023/05/21 11:34:28 PM    
I had tried everything mentioned in the suggestions, everything. None of them worked

So I uninstalled version 3.18 completely, and installed 3.11, that was working on my laptop.

It worked.

So I'd say there's a bug on version 3.18.

This web site is powered by Super Simple Server