Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

[Bug] Tixati loads trackers from different (wrong) torrent

by Guest on 2017/08/25 04:30:48 PM    
Hi,


I noticed a quite serious bug in version 2.55. When adding 2 torrents at the same time (adding two torrent files from disk),
with different set of trackers, the trackers for one get copied to the other one. I cannot yet say which set of trackers is kept,
from the one or the second. The original set of trackers of the torrent file are discarded. Loading that torrent file
a second time adds proper trackers, but keeps the copied ones.

I will provide more info if needed for reproducing this bug.


Thanks,
RimZi
by Guest on 2017/08/26 07:00:49 AM    
What OS?

are you loading torrents with the 'load transfer' window?

are you checking 'apply to all' and clicking start?

if so, it seems that it is using the trackers from the first torrent you are trying to add and applying them to the rest of the torrents you are trying to add.
by Guest on 2017/08/26 09:07:45 AM    
I just reproduced it again so I can answer your questions:

What OS?
Windows 10 64bit

are you loading torrents with the 'load transfer' window?
If you mean "Add new transfer", yes.

are you checking 'apply to all' and clicking start?
Yes, I am assigning a category and I do check the 'Apply to all' checkbox.

if so, it seems that it is using the trackers from the first torrent you are trying to add and applying them to the rest of the torrents you are trying to add.

Yes, first torrent's trackers are assigned to first and second torrents.
by dr_rimzi on 2018/01/12 01:02:26 PM    
Tested with 2.56.

The issue is still present.
by Guest on 2018/01/13 03:57:05 PM    
Any idea if this affects v2.53 ? Thank you.
by dr_rimzi on 2018/01/19 01:21:34 PM    
I don't know. I noticed it first in 2.55 when investigating why torrents are not downloading..
I have been using Tixati for a while now and 2.55 appears to be the first version with such a problem.
by SoCalDude on 2019/08/05 01:28:38 AM    
This issue is still present and frequent enough to be annoying. It happens when I download torrents, from two different trackers, on my phone,then move the torrent files to my PC (Windows 10), to the designated  directory where torrents are 'autoloaded' by Tixati.




This web site is powered by Super Simple Server