Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

error opening file for allocation

by Guest on 2016/05/04 06:57:55 AM    
I'm using 2.38 on window 7.

Had been working fine. Tried to download a couple of new torrents today, to the same location that has previously worked fine.
Was getting errors about writing the files to the disk. There is lots of space on the disk.
Update to 2.38 and getting a slightly different error, but still failing.

error opening file for allocation: The request could not be performed because of an I/O device error. (1117)

I've made sure to check the "Run this program as an administrator" box for the shortcut, using the latest version, retried a few times.

What should I check/try next?
by Bugmagnet on 2016/05/04 08:06:28 AM    
Is the location an internal drive or an external drive?

I'd suggest checking cables and running chkdsk to start with.

Does the torrent contain a file larger than 4 GB? How is the location drive formated? FAT32?  NTSF?
by Guest on 2016/05/04 08:56:55 AM    
The save location is an internal drive.

Ran chkdsk, it tells me that drive is in use by another process, but resource monitor says no one is using it.
It's made zero percent progress after 20 minutes...ack!
Other disks reported back from chkdsk fine and in relatively quick order.

Moved my save location to another drive, download is now working fine.

Must be some rogue process locking up the drive, or maybe a hardware failure, not convenient to reboot at the moment to check if it's a process.

Thanks for the help!!

Edit: Chkdsk made some progress, apparently a lot of file segments are now corrupted.
by Bugmagnet on 2016/05/05 06:15:54 AM    
you may want to do a full backup of that HDD immediately. The errors you are seeing might be signs of imminent drive failure.

After backup, You might want to run SpinRite from Gibson Research,
by faaaaq on 2016/06/17 04:49:20 AM    
I am getting this same error, 14gigs into a 15.5gig download.  Since the error, I have downloaded many other torrents of varying sizes, maybe 100gigs worth.  All to the same drive, which is a network drive.  All work fine, no errors.  I recheck and restart this torrent though, and every time it fails with this same error...  My drive is fine, shows no errors.  Id rather not have to move this file just to download it successfully.  Anyone have any more info to help us out?
by Guest on 2016/07/10 09:32:45 PM    

I'm having the same error since upgrading to version 2.43. I had no problem saving torrents to any of my drives and now I'm getting this error message for saving files in all my drives except one. All of my drives pass chkdsk without any problem. Any idea how to solve this problem? I tried to change the file allocation method but it did not have any effect on the problem.

Thanks in advance.
by oshmoz on 2016/07/16 03:49:19 PM    
Take a look at this posting:
by Guest on 2022/12/18 11:36:43 AM    
I'm using version 2.81 at the moment. Facing the same error. While some files even at 1.89 GB are downloading normally, rest of them aren't. Be it smaller or bigger in size. I think this partition having been compressed has to do something with this issue. No update, no other version solved it so far.
by Guest on 2022/12/18 09:18:09 PM    
I am also having this error - popped up recently as of Tixati 3.12.  I am using a Windows 10 machine for Tixati but the downloads are being  stored on a network drive physically connected to a Mac Mini running OS 10.13.10 - have been using this drive and Ma Mini and network for about 5 years, up to now with no issues.

Aside from this tixati thing everything else on the network (devices, etc.) is working fine.

I ran disk repair on the Mac Mini and the drive checks ou - no issues at all.

I also tried shutting down the Windows 10 machine, Mac Mini and my router and restarting them all, to see if it was a networking problem. This did not fix things: the issue remains.

In restarting the tixati download Tixati checked and is now 'allocating' the  3.5GB download file, but is 'allocating' at a rate of about 10-12 MB / min ... so allocating is gonna take a crazy long time......
by Guest on 2022/12/18 10:20:25 PM    
To add to my last comment, the error message I'm seeing is "error writing file while allocating: The parameter is incorrect. (87)"
by Guest on 2023/01/22 11:08:09 PM    
same today. it's only when i switched to a different partition that it did this. never happened in the past, everything worked fine and i could switch to different partitions freely. switching back solved the problem but i'm now concerned as to what caused this.

This web site is powered by Super Simple Server