Help and Support
Ask a question, report a problem, request a feature...
<<  Back To Forum

Cannot download to Virtualbox host shared drive from guest VM

by Guest on 2016/02/06 12:26:01 AM    
If anyone had this problem before, please share how you solved it

1) I have a host (ubuntu 14.04) running Virtualbox
2) There is a guest vm (lubuntu 15.10)
3) The host is sharing a folder with the guest
4) The folder is by default mounted on guest at /media/<my_folder_name> with permissions drwxrwx--- root vboxsf
5) The user running Tixati is in group vboxsf and can create files in the shared folder
6) However I cannot switch Tixati to download anything into shared folder - the OK button is greyed out in both Settings/Locations/Default Download Location  as well as when trying to change the Download location while adding a torrent

I'm not looking for criticism, just solving a problem

much appreciated
by Radish on 2016/02/06 12:59:52 PM    
5) The user running Tixati is in group vboxsf and can create files in the shared folder.

Maybe a bit of a long-shot, but have you tried subscribing the user to the "vboxusers" group as well.
by Guest on 2016/02/06 05:28:04 PM    
vboxusers group is not present on guest vm, it is there that I'm running tixati
that group is present on the host

what is interesting is that the same user running tixati can cd into mounted directory and do all file operations, but not from tixati
by Guest on 2016/02/07 01:41:46 AM    
I've also encountered this issue (Windows host, Linux Mint guest). I found it odd that both Transmission and qBittorrent are able to access the shared folder without additional setup. Besides permissions, would there be any other reason Tixati ever greys out that OK button in the directory selection dialog?
by Guest on 2016/02/07 06:02:23 PM    
OP Solved:

If anyone is interested as to why I wanted this setup, I wanted to secure all my torrenting behind a VPN and bind Tixati to a specific interface, in my case it is tun0.
My guess is Tixati has some constraints on directory ownership/permissions for downloads.

Remember to install VBox guest additions on guest, or waste time to figure out why this is not like that and that is not there :)

Do not set share on host to auto mount. That way you can manually mount it on guest and use the desired settings

# get your uid and gid
id -u <username> # my user = 1000
id -g <username> # my user = 1000

mkdir -p /home/<my user>/WD3TB

# try it out manually first
sudo mount -t vboxsf -o umask=0022,gid=1000,uid=1000 WD3TB /home/<my user>/host_shared/WD3TB/

# add an entry in /etc/fstab to load on boot
WD3TB /home/<my user>/host_shared/WD3TB/ vboxsf auto,uid=1000,gid=1000,dmask=027,fmask=137  0  0

- works
by Guest on 2016/02/08 03:28:59 PM    
Can confirm that manually mounting works (Windows host, Linux Mint guest). I though I had tried this before at some point but I must not have used the right options. Thanks for sharing.

I also had to add vboxsf to /etc/modules otherwise it wouldn't boot (an educational experience recovering from that).
Some folders within the share still could not be selected (even though sub folders could be) but recreating and moving the old files worked.
by Guest on 2018/10/10 09:43:53 PM    
This is a program killer for me. Just encountered this myself, and can't get it working. Tixati appears to be the only torrent client with this problem out of the box.
by Guest on 2020/09/26 08:55:34 PM    
Just ran into this today.  Been using XP guest for years on Win7 with no issues for Tixati to write to host shares.

Decided to get rid of XP guest and try Linux Mint.  Tixati can't seem to use the auto-mounted shares.  I can browse to them but OK button is greyed out.  On the guest I can write to them without any trouble.  I am using latest vbox with same release guest additions installed and everything is in perfect working order except for Tixati...

Can this issue with Tixati be fixed?

I will try the suggestion above to manually mount and script it, but would prefer if Tixati could handle this situation if at all possible.

Kind regards.
by Guest on 2021/06/07 12:51:28 PM    
Thankyou for this! Ive been trying to figure this out for weeks. For some reason tixati will only work in shared folders once they are mounted manually via fstab. I then had to create a folder within the shared directory using tixati download folder selection box. Then exit tixati and open the lubuntu default file browser and right click shared folder and got to properties then permissions and select view create and modify files for every user and group and press ok. Then reopen tixati and select the folders and they werent greyed out. Weird.
by Guest on 2023/12/07 02:10:45 PM    
Yeah, this is still an issue.

Can't set a public shared drive on my main PC as download location for Tixati running in a VirtualBox Linux dist.

Can't Tixati fix this?
by notaLamer on 2023/12/09 01:50:27 AM    
Sigh. Let's see what goes on.

- Host, Guest: Linux
- Guest Additions installed on Guest, relevant packages on Host too.
- VBox Shared Folders: Create, choose a path, Folder name it "can-i-see-this", Auto mount=yes, Permanent = yes. OK

In terminal:
myuser$ mount | grep vbox
can-i-see-this on /media/sf_can-i-see-this type vboxsf (rw,nodev,relatime)
Found the mount. Can we look inside?
myuser$ ls -l /media/sf_can-i-see-this type
ls: cannot open directory '/media/sf_can-i-see-this': Permission denied
OK weird. We can ls the /media/ folder to see who owns the mounted folder:

$ ls -l /media
total 8
drwxrwx--- 1 root vboxsf 4096 22 jan  2021 sf_can-i-see-this
"root" is the owning user, "vboxsf" is the owning group. Both have full permissions, but --- means anybody else has no rights whatsoever.

Apparently my user doesn't belong to vboxsf group. Can we prove it?

1. If you have command groups enter it to show your CURRENT own groups.

2. Otherwise see if "vboxsf" has any users assigned in settings:
myuser$ grep -F "vboxsf" /etc/group
There are no users after the last semicolon.

Add myself to "vboxsf" group.

myuser$ usermod --help; sudo usermod --append --groups "vboxsf" "$(whoami)"

NOTE: You will show up in (2) group settings, but not in (1) current groups.

myuser$ groups
... vboxsf ... myuser

myuser$ ls -l /media/

myuser$ ls -l /media/sf_can-i-see-this
total 8
-rwxrwx--- 1 root vboxsf 1234 11 sep  2010 custom.cfg
-rwxrwx--- 1 root vboxsf 5678 11 sep  2010 options.cfg

Write a file:
myuser$ echo "Hello from Linux VM" > /media/sf_can-i-see-this/message.txt

Conclusion: User error.
Workaround: Give yourself the supplementary group vboxsf
Fix: Ask your distro maintainers why they decided to not add your system user to the vboxsf group so shared folders would work automatically.
Tixati dev: Add a text line that says "No write permission in selected folder" when OK is grayed out.

@Tixati Dev: Can you put the wiki page I will soon finish under "Sections" on the support page?

by Guest on 2024/01/20 03:03:36 PM    
The answer of notaLamer doesn't address the originally reported issue:

It is not possible to select folders on automounted Virtualbox shares in the Tixati configuration dialog as download locations, even if the user running Tixati (which is already in the vboxsf group) is able to read/write on the shares with all other applications.

He was only missing one last step in reproducing it: trying to make Tixati actually use the share
by Guest on 2024/01/23 01:46:56 PM    
Correct, and all the steps where already done.
Added a line in FSTAB and it worked then.
At least until the latest UBUNTU update...

"user error", not really.
Other clients work.
by Guest on 2024/01/23 01:55:16 PM    
The latest update seems to have reset folder owner and rights, so that was easy.

This web site is powered by Super Simple Server